<!doctype html >
<!--[if IE 8]><html
class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]><html
class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--><html
lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><title>Museum Memories - The Cordova Times</title><meta
charset="UTF-8" /><meta
name="viewport" content="width=device-width, initial-scale=1.0"><link
rel="pingback" href="http://www.thecordovatimes.com/xmlrpc.php" /><meta
property="og:image" content="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg" /><meta
name="author" content="The Cordova Times"><link
rel="canonical" href="http://www.thecordovatimes.com/2017/05/13/museum-memories-24/" /><meta
property="og:locale" content="en_US" /><meta
property="og:type" content="article" /><meta
property="og:title" content="Museum Memories - The Cordova Times" /><meta
property="og:description" content="This month marks the 51st anniversary of the founding of the Cordova Historical Society and the 50th anniversary of the first community museum in Cordova. An enthused group of dedicated individuals noted the need to start recording the very interesting story of the community. In 1966, they founded the Cordova Historical Society and then utilizing &hellip;" /><meta
property="og:url" content="http://www.thecordovatimes.com/2017/05/13/museum-memories-24/" /><meta
property="og:site_name" content="The Cordova Times" /><meta
property="article:tag" content="alaska" /><meta
property="article:tag" content="cordova" /><meta
property="article:tag" content="Historical Society" /><meta
property="article:tag" content="museum memories" /><meta
property="article:tag" content="sherman" /><meta
property="article:section" content="Museum Memories" /><meta
property="article:published_time" content="2017-05-13T08:00:48-08:00" /><meta
property="article:modified_time" content="2017-05-10T21:08:48-08:00" /><meta
property="og:updated_time" content="2017-05-10T21:08:48-08:00" /><meta
property="og:image" content="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg" /><meta
property="og:image:width" content="640" /><meta
property="og:image:height" content="388" /><meta
name="twitter:card" content="summary" /><meta
name="twitter:description" content="This month marks the 51st anniversary of the founding of the Cordova Historical Society and the 50th anniversary of the first community museum in Cordova. An enthused group of dedicated individuals noted the need to start recording the very interesting story of the community. In 1966, they founded the Cordova Historical Society and then utilizing [&hellip;]" /><meta
name="twitter:title" content="Museum Memories - The Cordova Times" /><meta
name="twitter:image" content="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg" /><link
rel='dns-prefetch' href='//fonts.googleapis.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
rel="alternate" type="application/rss+xml" title="The Cordova Times &raquo; Feed" href="http://www.thecordovatimes.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="The Cordova Times &raquo; Comments Feed" href="http://www.thecordovatimes.com/comments/feed/" /><link
rel="alternate" type="text/calendar" title="The Cordova Times &raquo; iCal Feed" href="http://www.thecordovatimes.com/events/?ical=1" /><link
rel="alternate" type="application/rss+xml" title="The Cordova Times &raquo; Museum Memories Comments Feed" href="http://www.thecordovatimes.com/2017/05/13/museum-memories-24/feed/" /> <script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.thecordovatimes.com\/wp-includes\/js\/wp-emoji-release.min.js"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link
rel='stylesheet' id='contact-form-7-css'  href='http://www.thecordovatimes.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' /><link
rel='stylesheet' id='wpt-twitter-feed-css'  href='http://www.thecordovatimes.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' /><link
rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.7.5' type='text/css' media='all' /><link
rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.7.5' type='text/css' media='all' /><link
rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=PT+Sans+Caption%3A400%2C700%7CPT+Sans%3A400%2C700%7CPT+Serif%3A400%2C700%7CPT+Serif+Caption%3A400%2C700&#038;ver=4.7.5' type='text/css' media='all' /><link
rel='stylesheet' id='js_composer_front-css'  href='http://www.thecordovatimes.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css' type='text/css' media='all' /><link
rel='stylesheet' id='td-theme-css'  href='http://www.thecordovatimes.com/wp-content/themes/Newspaper/style.css' type='text/css' media='all' /> <script type='text/javascript' src='http://www.thecordovatimes.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='http://www.thecordovatimes.com/wp-includes/js/jquery/jquery-migrate.min.js'></script> <link
rel='https://api.w.org/' href='http://www.thecordovatimes.com/wp-json/' /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.thecordovatimes.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.thecordovatimes.com/wp-includes/wlwmanifest.xml" /><meta
name="generator" content="WordPress 4.7.5" /><link
rel='shortlink' href='http://www.thecordovatimes.com/?p=7428' /><link
rel="alternate" type="application/json+oembed" href="http://www.thecordovatimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thecordovatimes.com%2F2017%2F05%2F13%2Fmuseum-memories-24%2F" /><link
rel="alternate" type="text/xml+oembed" href="http://www.thecordovatimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thecordovatimes.com%2F2017%2F05%2F13%2Fmuseum-memories-24%2F&#038;format=xml" /><meta
name="tec-api-version" content="v1"><meta
name="tec-api-origin" content="http://www.thecordovatimes.com"><link
rel="htt://theeventscalendar.com" href="http://www.thecordovatimes.com/wp-json/tribe/events/v1/" /><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><style type="text/css">.recentcomments
a{display:inline !important;padding:0
!important;margin:0
!important}</style><meta
name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link
rel="stylesheet" type="text/css" href="http://www.thecordovatimes.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link
rel="stylesheet" type="text/css" href="http://www.thecordovatimes.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-83533033-1','auto');ga('send','pageview');</script> <script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var tds_login_sing_in_widget="show";var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .post img";var td_ajax_url="http:\/\/www.thecordovatimes.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.3";var td_get_template_directory_uri="http:\/\/www.thecordovatimes.com\/wp-content\/themes\/Newspaper";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="9";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="show";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#649bce";var tds_smart_sidebar="";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var td_ad_background_click_link="";var td_ad_background_click_target="";</script> <style>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</style><link
rel="icon" href="http://www.thecordovatimes.com/wp-content/uploads/2016/05/cropped-Icon-32x32.png" sizes="32x32" /><link
rel="icon" href="http://www.thecordovatimes.com/wp-content/uploads/2016/05/cropped-Icon-192x192.png" sizes="192x192" /><link
rel="apple-touch-icon-precomposed" href="http://www.thecordovatimes.com/wp-content/uploads/2016/05/cropped-Icon-180x180.png" /><meta
name="msapplication-TileImage" content="http://www.thecordovatimes.com/wp-content/uploads/2016/05/cropped-Icon-270x270.png" />
<noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body
class="post-template-default single single-post postid-7428 single-format-standard tribe-no-js museum-memories-24 single_template wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div
class="td-scroll-up"><i
class="td-icon-menu-up"></i></div><div
class="td-menu-background"></div><div
id="td-mobile-nav"><div
class="td-mobile-container"><div
class="td-menu-socials-wrap"><div
class="td-menu-socials">
<span
class="td-social-icon-wrap">
<a
target="_blank" href="https://www.facebook.com/thecordovatimes/" title="Facebook">
<i
class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span
class="td-social-icon-wrap">
<a
target="_blank" href="https://www.instagram.com/thecordovatimes/" title="Instagram">
<i
class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span
class="td-social-icon-wrap">
<a
target="_blank" href="https://twitter.com/thecordovatimes" title="Twitter">
<i
class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div
class="td-mobile-close">
<a
href="#"><i
class="td-icon-close-mobile"></i></a></div></div><div
class="td-menu-login-section"><div
class="td-guest-wrap"><div
class="td-menu-avatar"><div
class="td-avatar-container"><img
alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&amp;d=mm&amp;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div><div
class="td-menu-login"><a
id="login-link-mob">Sign in</a></div></div></div><div
class="td-mobile-content"><div
class="menu-main-menu-container"><ul
id="menu-main-menu" class="td-mobile-main-menu"><li
id="menu-item-2122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-2122"><a
href="http://www.thecordovatimes.com">Home</a></li><li
id="menu-item-2118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2118"><a
href="http://www.thecordovatimes.com/category/local/">Local</a></li><li
id="menu-item-2119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2119"><a
href="http://www.thecordovatimes.com/category/fisheries/">Fisheries</a></li><li
id="menu-item-3369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3369"><a
href="http://www.thecordovatimes.com/category/cordova-culture/">Cordova Culture</a></li><li
id="menu-item-3370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3370"><a
href="http://www.thecordovatimes.com/category/alaska/">Alaska</a></li><li
id="menu-item-2698" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2698"><a
href="http://www.thecordovatimes.com/category/community/">Community</a></li><li
id="menu-item-3644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3644"><a
href="http://www.thecordovatimes.com/events/">Events</a></li><li
id="menu-item-2121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2121"><a
href="http://www.thecordovatimes.com/category/opinion/">Opinion</a></li><li
id="menu-item-3948" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3948"><a
href="http://www.thecordovatimes.com/classifieds/">Classifieds</a></li><li
id="menu-item-3415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3415"><a
href="http://www.thecordovatimes.com/subscribe/">Subscribe</a></li></ul></div></div></div><div
id="login-form-mobile" class="td-register-section"><div
id="td-login-mob" class="td-login-animation td-login-hide-mob"><div
class="td-login-close">
<a
href="#" class="td-back-button"><i
class="td-icon-read-down"></i></a><div
class="td-login-title">Sign in</div><div
class="td-mobile-close">
<a
href="#"><i
class="td-icon-close-mobile"></i></a></div></div><div
class="td-login-form-wrap"><div
class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div
class="td-login-inputs"><input
class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input
type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div
class="td-login-info-text"><a
href="#" id="forgot-pass-link-mob">Forgot your password?</a></div></div></div><div
id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div
class="td-forgot-pass-close">
<a
href="#" class="td-back-button"><i
class="td-icon-read-down"></i></a><div
class="td-login-title">Password recovery</div></div><div
class="td-login-form-wrap"><div
class="td-login-panel-title">Recover your password</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input
type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div
class="td-search-background"></div><div
class="td-search-wrap-mob"><div
class="td-drop-down-search" aria-labelledby="td-header-search-button"><form
method="get" class="td-search-form" action="http://www.thecordovatimes.com/"><div
class="td-search-close">
<a
href="#"><i
class="td-icon-close-mobile"></i></a></div><div
role="search" class="td-search-input">
<span>Search</span>
<input
id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div
id="td-aj-search-mob"></div></div></div><div
id="td-outer-wrap"><div
class="td-header-wrap td-header-style-9"><div
class="td-header-top-menu-full"><div
class="td-container td-header-row td-header-top-menu"><div
class="top-bar-style-1"><div
class="td-header-sp-top-menu"><div
class="td-weather-top-widget" id="td_top_weather_uid">
<i
class="td-icons rain-n"></i><div
class="td-weather-now" data-block-uid="td_top_weather_uid">
<span
class="td-big-degrees">46.4</span>
<span
class="td-weather-unit">F</span></div><div
class="td-weather-header"><div
class="td-weather-city">Cordova, AK</div></div></div><div
class="td_data_time"><div >Wednesday, May 17, 2017</div></div><ul
class="top-header-menu td_ul_login"><li
class="menu-item"><a
class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span
class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div
class="menu-top-container"><ul
id="menu-sub-menu" class="top-header-menu"><li
id="menu-item-3421" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-3421"><a
href="http://www.thecordovatimes.com/">Home</a></li><li
id="menu-item-3414" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3414"><a
href="http://www.thecordovatimes.com/advertise/">Advertise</a></li><li
id="menu-item-3406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3406"><a
href="http://www.thecordovatimes.com/subscribe/">Subscribe</a></li><li
id="menu-item-3408" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3408"><a
href="http://www.thecordovatimes.com/about-us/">About Us</a></li><li
id="menu-item-3407" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3407"><a
href="http://www.thecordovatimes.com/contact-us/">Contact Us</a></li></ul></div></div></div><div
id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div
class="td-login-wrap">
<a
href="#" class="td-back-button"><i
class="td-icon-modal-back"></i></a><div
id="td-login-div" class="td-login-form-div td-display-block"><div
class="td-login-panel-title">Sign in</div><div
class="td-login-panel-descr">Welcome! Log into your account</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div
class="td-login-inputs"><input
class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input
type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div
class="td-login-info-text"><a
href="#" id="forgot-pass-link">Forgot your password? Get help</a></div></div><div
id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div
class="td-login-panel-title">Password recovery</div><div
class="td-login-panel-descr">Recover your password</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input
type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div
class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div
class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded"><div
class="td-header-sp-logo">
<a
class="td-main-logo" href="http://www.thecordovatimes.com/">
<img
class="td-retina-data"  data-retina="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead3.png" src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead3.png" alt="The Cordova Times"/>
<span
class="td-visual-hidden">The Cordova Times</span>
</a></div></div><div
class="td-header-menu-wrap-full"><div
class="td-header-menu-wrap td-header-gradient"><div
class="td-container td-header-row td-header-main-menu"><div
id="td-header-menu" role="navigation"><div
id="td-top-mobile-toggle"><a
href="#"><i
class="td-icon-font td-icon-mobile"></i></a></div><div
class="td-main-menu-logo td-logo-in-header">
<a
class="td-mobile-logo td-sticky-disable" href="http://www.thecordovatimes.com/">
<img
class="td-retina-data" data-retina="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead-Mobile-RETINA.png" src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead-Mobile.png" alt="The Cordova Times"/>
</a>
<a
class="td-header-logo td-sticky-disable" href="http://www.thecordovatimes.com/">
<img
class="td-retina-data" data-retina="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead3.png" src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead3.png" alt="The Cordova Times"/>
</a></div><div
class="menu-main-menu-container"><ul
id="menu-main-menu-1" class="sf-menu"><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-2122"><a
href="http://www.thecordovatimes.com">Home</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2118"><a
href="http://www.thecordovatimes.com/category/local/">Local</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2119"><a
href="http://www.thecordovatimes.com/category/fisheries/">Fisheries</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3369"><a
href="http://www.thecordovatimes.com/category/cordova-culture/">Cordova Culture</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3370"><a
href="http://www.thecordovatimes.com/category/alaska/">Alaska</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2698"><a
href="http://www.thecordovatimes.com/category/community/">Community</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3644"><a
href="http://www.thecordovatimes.com/events/">Events</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2121"><a
href="http://www.thecordovatimes.com/category/opinion/">Opinion</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3948"><a
href="http://www.thecordovatimes.com/classifieds/">Classifieds</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3415"><a
href="http://www.thecordovatimes.com/subscribe/">Subscribe</a></li></ul></div></div><div
class="td-search-wrapper"><div
id="td-top-search"><div
class="header-search-wrap"><div
class="dropdown header-search">
<a
id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i
class="td-icon-search"></i></a>
<a
id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i
class="td-icon-search"></i></a></div></div></div></div><div
class="header-search-wrap"><div
class="dropdown header-search"><div
class="td-drop-down-search" aria-labelledby="td-header-search-button"><form
method="get" class="td-search-form" action="http://www.thecordovatimes.com/"><div
role="search" class="td-head-form-search-wrap">
<input
id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input
class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div
id="td-aj-search"></div></div></div></div></div></div></div><div
class="td-banner-wrap-full td-banner-bg"><div
class="td-container-header td-header-row td-header-header"><div
class="td-header-sp-recs"><div
class="td-header-rec-wrap"></div></div></div></div></div><div
class="td-main-content-wrap"><div
class="td-container td-post-template-default "><div
class="td-crumb-container"></div><div
class="td-pb-row"><div
class="td-pb-span8 td-main-content" role="main"><div
class="td-ss-main-content">
<article
id="post-7428" class="post-7428 post type-post status-publish format-standard has-post-thumbnail hentry category-museum-memories tag-alaska tag-cordova tag-historical-society tag-museum-memories tag-sherman" itemscope itemtype="http://schema.org/Article"><div
class="td-post-header">
<header
class="td-post-title"><h1 class="entry-title">Museum Memories</h1><div
class="td-module-meta-info"><div
class="td-post-author-name"><div
class="td-author-by">By</div> <a
href="http://www.thecordovatimes.com/author/thecordovatimes/">The Cordova Times</a><div
class="td-author-line"> -</div></div>                    <span
class="td-post-date"><time
class="entry-date updated td-module-date" datetime="2017-05-13T08:00:48+00:00" >May 13, 2017</time></span></div></header></div><div
class="td-post-content"><div
class="td-post-featured-image"><a
href="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg" data-caption=""><img
width="640" height="388" class="entry-thumb td-modal-image" src="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg" alt="" title="CT 05-12 museum memories"/></a></div><div
class="td-a-rec td-a-rec-id-content_top  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p "><div
class="td-a-rec td-a-rec-id-smart_list_6  "><div
class="td-visible-desktop">
<a
href="http://www.thecordovatimes.com/advertise/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/09/CT-Advertise-300x250@2x.png" alt="" class="td-animation-stack-type0-2"></a></div><div
class="td-visible-tablet-landscape">
<a
href="http://www.thecordovatimes.com/advertise/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/09/CT-Advertise-300x250@2x.png" alt="" class="td-animation-stack-type0-2"></a></div><div
class="td-visible-tablet-portrait">
<a
href="http://www.thecordovatimes.com/advertise/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/09/CT-Advertise-300x250@2x.png" alt="" class="td-animation-stack-type0-2"></a></div><div
class="td-visible-phone">
<a
href="http://www.thecordovatimes.com/advertise/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/09/CT-Advertise-300x250@2x.png" alt="" class="td-animation-stack-type0-2"></a></div></div></div><p>This month marks the 51<span
data-fontsize="12">st</span> anniversary of the founding of the Cordova Historical Society and the 50<span
data-fontsize="12">th</span> anniversary of the first community museum in Cordova. An enthused group of dedicated individuals noted the need to start recording the very interesting story of the community. In 1966, they founded the Cordova Historical Society and then utilizing Alaska State Centennial grant funds built the Cordova Historical Museum. Constructed in 1967 and located on First Street; the Cordova Public Library addition was added in 1971 after it outgrew its home in the lobby of the Windsor Hotel.</p><p><b><i>This photo came from the archives and collections of the Cordova Historical Society.</i></b></p><div
class="td-a-rec td-a-rec-id-content_bottom  "><div
class="td-a-rec td-a-rec-id-smart_list_6  "><div
class="td-visible-desktop">
<a
href="http://www.thecordovatimes.com/advertise/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Advertise-468x60.png" alt="" class="td-animation-stack-type0-2"></a></div><div
class="td-visible-tablet-landscape">
<a
href="http://www.thecordovatimes.com/advertise/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Advertise-468x60.png" alt="" class="td-animation-stack-type0-2"></a></div><div
class="td-visible-tablet-portrait">
<a
href="http://www.thecordovatimes.com/advertise/"><http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Advertise-468x60.png" alt="" class="td-animation-stack-type0-2"></a></div><div
class="td-visible-phone">
<a
href="http://www.thecordovatimes.com/advertise/"><http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Advertise-468x60.png" alt="" class="td-animation-stack-type0-2"></a></div></div></div></div><footer><div
class="td-post-source-tags"></div><div
class="td-post-sharing td-post-sharing-bottom "><span
class="td-post-share-title">SHARE</span><div
class="td-default-sharing">
<a
class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.thecordovatimes.com%2F2017%2F05%2F13%2Fmuseum-memories-24%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i
class="td-icon-facebook"></i><div
class="td-social-but-text">Facebook</div></a>
<a
class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Museum+Memories&url=http%3A%2F%2Fwww.thecordovatimes.com%2F2017%2F05%2F13%2Fmuseum-memories-24%2F&via=thecordovatimes"><i
class="td-icon-twitter"></i><div
class="td-social-but-text">Twitter</div></a>
<a
class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://www.thecordovatimes.com/2017/05/13/museum-memories-24/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i
class="td-icon-googleplus"></i></a>
<a
class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://www.thecordovatimes.com/2017/05/13/museum-memories-24/&amp;media=http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg&description=Museum+Memories" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i
class="td-icon-pinterest"></i></a>
<a
class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Museum+Memories%20-%20http%3A%2F%2Fwww.thecordovatimes.com%2F2017%2F05%2F13%2Fmuseum-memories-24%2F" ><i
class="td-icon-whatsapp"></i></a></div></div><div
class="td-block-row td-post-next-prev"><div
class="td-block-span6 td-post-prev-post"><div
class="td-post-next-prev-content"><span>Previous article</span><a
href="http://www.thecordovatimes.com/2017/05/13/cordova-chronicles-news-world-morning-coffee/">Cordova Chronicles: News of the world with your morning coffee</a></div></div><div
class="td-next-prev-separator"></div><div
class="td-block-span6 td-post-next-post"><div
class="td-post-next-prev-content"><span>Next article</span><a
href="http://www.thecordovatimes.com/2017/05/14/real-id-bills-move-forward-legislature/">REAL ID bills move forward in Legislature</a></div></div></div><div
class="author-box-wrap"><a
href="http://www.thecordovatimes.com/author/thecordovatimes/"><img
alt='' src='http://0.gravatar.com/avatar/ceeba3cb0474e20d6675547d6057f7ec?s=96&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/ceeba3cb0474e20d6675547d6057f7ec?s=192&amp;d=mm&amp;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div
class="desc"><div
class="td-author-name vcard author"><span
class="fn"><a
href="http://www.thecordovatimes.com/author/thecordovatimes/">The Cordova Times</a></span></div><div
class="td-author-description">The Cordova Times is Prince William Sound's oldest newspaper, publishing since 1914. Send story ideas and news tips to news@thecordovatimes.com.</div><div
class="td-author-social"></div><div
class="clearfix"></div></div></div>	        <span
style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta
itemprop="name" content="The Cordova Times"></span><meta
itemprop="datePublished" content="2017-05-13T08:00:48+00:00"><meta
itemprop="dateModified" content="2017-05-10T21:08:48+00:00"><meta
itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.thecordovatimes.com/2017/05/13/museum-memories-24/"/><span
style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span
style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta
itemprop="url" content="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-Masthead3.png"></span><meta
itemprop="name" content="The Cordova Times"></span><meta
itemprop="headline " content="Museum Memories"><span
style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta
itemprop="url" content="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-12-museum-memories.jpg"><meta
itemprop="width" content="640"><meta
itemprop="height" content="388"></span>        </footer></article><div
class="td_block_wrap td_block_related_posts td_uid_4_591d3d04705b0_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_591d3d04705b0" ><script>var block_td_uid_4_591d3d04705b0=new tdBlock();block_td_uid_4_591d3d04705b0.id="td_uid_4_591d3d04705b0";block_td_uid_4_591d3d04705b0.atts='{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_591d3d04705b0_rand","offset":"","css":"","live_filter":"cur_post_same_categories","live_filter_cur_post_id":7428,"live_filter_cur_post_author":"1"}';block_td_uid_4_591d3d04705b0.td_column_number="3";block_td_uid_4_591d3d04705b0.block_type="td_block_related_posts";block_td_uid_4_591d3d04705b0.post_count="3";block_td_uid_4_591d3d04705b0.found_posts="34";block_td_uid_4_591d3d04705b0.header_color="";block_td_uid_4_591d3d04705b0.ajax_pagination_infinite_stop="";block_td_uid_4_591d3d04705b0.max_num_pages="12";tdBlocksArray.push(block_td_uid_4_591d3d04705b0);</script><h4 class="td-related-title"><a
id="td_uid_5_591d3d047291c" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_591d3d04705b0" href="#">RELATED ARTICLES</a><a
id="td_uid_6_591d3d0472960" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_591d3d04705b0" href="#">MORE FROM AUTHOR</a></h4><div
id=td_uid_4_591d3d04705b0 class="td_block_inner"><div
class="td-related-row"><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="http://www.thecordovatimes.com/2017/05/07/museum-memories-23/" rel="bookmark" title="Museum Memories"><img
width="218" height="150" class="entry-thumb" src="http://www.thecordovatimes.com/wp-content/uploads/2017/05/CT-05-05-museum-memories-1-218x150.jpg" alt="" title="Museum Memories"/></a></div>                <a
href="http://www.thecordovatimes.com/category/city-of-cordova/museum-memories/" class="td-post-category">Museum Memories</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="http://www.thecordovatimes.com/2017/05/07/museum-memories-23/" rel="bookmark" title="Museum Memories">Museum Memories</a></h3></div></div></div><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="http://www.thecordovatimes.com/2017/04/25/museum-memories-22/" rel="bookmark" title="Museum Memories"><img
width="218" height="150" class="entry-thumb" src="http://www.thecordovatimes.com/wp-content/uploads/2017/04/CT-04-21-museum-memories-1-218x150.jpg" alt="" title="Museum Memories"/></a></div>                <a
href="http://www.thecordovatimes.com/category/city-of-cordova/museum-memories/" class="td-post-category">Museum Memories</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="http://www.thecordovatimes.com/2017/04/25/museum-memories-22/" rel="bookmark" title="Museum Memories">Museum Memories</a></h3></div></div></div><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="http://www.thecordovatimes.com/2017/04/14/museum-memories-21/" rel="bookmark" title="Museum Memories"><img
width="218" height="150" class="entry-thumb" src="http://www.thecordovatimes.com/wp-content/uploads/2017/04/CT-04-14-museum-memories-1-218x150.jpg" alt="" title="Museum Memories"/></a></div>                <a
href="http://www.thecordovatimes.com/category/city-of-cordova/museum-memories/" class="td-post-category">Museum Memories</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="http://www.thecordovatimes.com/2017/04/14/museum-memories-21/" rel="bookmark" title="Museum Memories">Museum Memories</a></h3></div></div></div></div></div><div
class="td-next-prev-wrap"><a
href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_591d3d04705b0" data-td_block_id="td_uid_4_591d3d04705b0"><i
class="td-icon-font td-icon-menu-left"></i></a><a
href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_591d3d04705b0" data-td_block_id="td_uid_4_591d3d04705b0"><i
class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div><div
class="td-pb-span4 td-main-sidebar" role="complementary"><div
class="td-ss-main-sidebar">
<aside
class="widget widget_text"><div
class="textwidget"></div>
</aside>		<aside
class="widget widget_recent_entries"><div
class="block-title"><span>Recent Posts</span></div><ul><li>
<a
href="http://www.thecordovatimes.com/2017/05/17/protective-measures-sought-vessel-traffic-rises/">Protective measures sought as vessel traffic rises</a></li><li>
<a
href="http://www.thecordovatimes.com/2017/05/17/fisheries-board-says-no-emergency-petition-copper-river-fishery/">Fisheries board says no to emergency petition on Copper River fishery</a></li><li>
<a
href="http://www.thecordovatimes.com/2017/05/17/two-judges-named-anchorage-superior-court/">Two judges named to Anchorage Superior Court</a></li><li>
<a
href="http://www.thecordovatimes.com/2017/05/16/select-lots-multi-grain-alaskan-cod-recalled/">Select lots of Multi-Grain Alaskan Cod recalled</a></li><li>
<a
href="http://www.thecordovatimes.com/2017/05/16/house-bill-create-benefit-corporations/">House bill would create benefit corporations</a></li></ul>
</aside><div
class="td_block_wrap td_block_social_counter td_block_widget td_uid_7_591d3d047a0a5_rand td-social-style4 td-social-colored td-pb-border-top"><h4 class="block-title"><span>STAY CONNECTED</span></h4><div
class="td-social-list"><div
class="td_social_type td-pb-margin-side td_social_facebook"><div
class="td-social-box"><div
class="td-sp td-sp-facebook"></div><span
class="td_social_info">2,461</span><span
class="td_social_info td_social_info_name">Fans</span><span
class="td_social_button"><a
href="https://www.facebook.com/thecordovatimes" target="_blank">Like</a></span></div></div><div
class="td_social_type td-pb-margin-side td_social_twitter"><div
class="td-social-box"><div
class="td-sp td-sp-twitter"></div><span
class="td_social_info">75</span><span
class="td_social_info td_social_info_name">Followers</span><span
class="td_social_button"><a
href="https://twitter.com/@thecordovatimes" target="_blank">Follow</a></span></div></div><div
class="clearfix"></div></div></div> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div
class="td-g-rec td-g-rec-id-custom_ad_1 "> <script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-7398005988893005" data-ad-slot="2227187575"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-7398005988893005" data-ad-slot="2227187575"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-7398005988893005" data-ad-slot="2227187575"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-7398005988893005" data-ad-slot="2227187575"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script> </div><div
class="td-a-rec td-a-rec-id-custom_ad_3  "><div
class="td-a-rec td-a-rec-id-smart_list_6  "><div
class="td-visible-desktop">
<a
href="http://www.thecordovatimes.com/advertise/"><img
class="td-retina" style="max-width:300px" src="http://www.thecordovatimes.com/wp-content/uploads/2017/05/Advertise-300x250.jpg"></a></div><div
class="td-visible-tablet-landscape">
<a
href="http://www.thecordovatimes.com/advertise/"><img
class="td-retina" style="max-width:300px" src="http://www.thecordovatimes.com/wp-content/uploads/2017/05/Advertise-300x250.jpg"></a></div><div
class="td-visible-tablet-portrait">
<a
href="http://www.thecordovatimes.com/advertise/"><img
class="td-retina" style="max-width:300px" src="http://www.thecordovatimes.com/wp-content/uploads/2017/05/Advertise-300x250.jpg"></a></div><div
class="td-visible-phone">
<a
href="http://www.thecordovatimes.com/advertise/"><img
class="td-retina" style="max-width:300px" src="http://www.thecordovatimes.com/wp-content/uploads/2017/05/Advertise-300x250.jpg"></a></div></div></div><aside
class="widget widget_text"><div
class="textwidget"></div>
</aside><aside
class="widget widget_archive"><div
class="block-title"><span>Cordova Archives</span></div>		<label
class="screen-reader-text" for="archives-dropdown-3">Cordova Archives</label>
<select
id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'><option
value="">Select Month</option><option
value='http://www.thecordovatimes.com/2017/05/'> May 2017</option><option
value='http://www.thecordovatimes.com/2017/04/'> April 2017</option><option
value='http://www.thecordovatimes.com/2017/03/'> March 2017</option><option
value='http://www.thecordovatimes.com/2017/02/'> February 2017</option><option
value='http://www.thecordovatimes.com/2017/01/'> January 2017</option><option
value='http://www.thecordovatimes.com/2016/12/'> December 2016</option><option
value='http://www.thecordovatimes.com/2016/11/'> November 2016</option><option
value='http://www.thecordovatimes.com/2016/10/'> October 2016</option><option
value='http://www.thecordovatimes.com/2016/09/'> September 2016</option><option
value='http://www.thecordovatimes.com/2016/08/'> August 2016</option><option
value='http://www.thecordovatimes.com/2016/07/'> July 2016</option><option
value='http://www.thecordovatimes.com/2016/06/'> June 2016</option><option
value='http://www.thecordovatimes.com/2016/05/'> May 2016</option></select>
</aside><aside
class="widget widget_search"><form
method="get" class="td-search-form-widget" action="http://www.thecordovatimes.com/"><div
role="search">
<input
class="td-widget-search-input" type="text" value="" name="s" id="s" /><input
class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" /></div></form></aside></div></div></div></div></div><div
class="td-footer-wrapper td-footer-template-4"><div
class="td-container"><div
class="td-pb-row"><div
class="td-pb-span12"></div></div><div
class="td-pb-row"><div
class="td-pb-span12"><div
class="td-footer-info"><div
class="footer-logo-wrap"><a
href="http://www.thecordovatimes.com/"><img
src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/IconSMALL.png" alt="The Cordova Times" title=""/></a></div><div
class="footer-text-wrap">Prince William Sound's Oldest Newspaper. Established 1914. Tribally owned.<div
class="footer-email-wrap">Contact us: <a
href="mailto:news@thecordovatimes.com">news@thecordovatimes.com</a></div></div><div
class="footer-social-wrap td-social-style-2"></div></div></div></div></div></div><div
class="td-sub-footer-container"><div
class="td-container"><div
class="td-pb-row"><div
class="td-pb-span7 td-sub-footer-menu"><div
class="menu-sub-menu-container"><ul
id="menu-sub-menu-1" class="td-subfooter-menu"><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-3421"><a
href="http://www.thecordovatimes.com/">Home</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3414"><a
href="http://www.thecordovatimes.com/advertise/">Advertise</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3406"><a
href="http://www.thecordovatimes.com/subscribe/">Subscribe</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3408"><a
href="http://www.thecordovatimes.com/about-us/">About Us</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3407"><a
href="http://www.thecordovatimes.com/contact-us/">Contact Us</a></li></ul></div></div><div
class="td-pb-span5 td-sub-footer-copy">
&copy; 2016 The Cordova Times and Native Village of Eyak. All rights reserved.</div></div></div></div></div> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js');})(document.body);</script> <div
class="td-more-articles-box">
<i
class="td-icon-close td-close-more-articles-box"></i>
<span
class="td-more-articles-box-title">MORE STORIES</span><div
class="td-content-more-articles-box"><div
class="td_module_6 td_module_wrap td-animation-stack"><div
class="td-module-thumb"><a
href="http://www.thecordovatimes.com/2016/06/24/museum-memories-3/" rel="bookmark" title="Museum Memories"><img
width="100" height="70" class="entry-thumb" src="http://www.thecordovatimes.com/wp-content/uploads/2016/08/CT-06-24-Museum-Memories-95-72-188-100x70.jpg" alt="" title="Museum Memories"/></a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="http://www.thecordovatimes.com/2016/06/24/museum-memories-3/" rel="bookmark" title="Museum Memories">Museum Memories</a></h3><div
class="td-module-meta-info">
<span
class="td-post-date"><time
class="entry-date updated td-module-date" datetime="2016-06-24T04:38:47+00:00" >June 24, 2016</time></span></div></div></div><div
class="td_module_6 td_module_wrap td-animation-stack"><div
class="td-module-thumb"><a
href="http://www.thecordovatimes.com/2017/03/21/museum-memories-19/" rel="bookmark" title="Museum Memories"><img
width="100" height="70" class="entry-thumb" src="http://www.thecordovatimes.com/wp-content/uploads/2017/03/CT-03-17-Museum-Memories-1-100x70.jpg" alt="" title="Museum Memories"/></a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="http://www.thecordovatimes.com/2017/03/21/museum-memories-19/" rel="bookmark" title="Museum Memories">Museum Memories</a></h3><div
class="td-module-meta-info">
<span
class="td-post-date"><time
class="entry-date updated td-module-date" datetime="2017-03-21T16:33:49+00:00" >March 21, 2017</time></span></div></div></div></div></div><style type="text/css" media="screen">body.td-animation-stack-type0 .td-animation-stack .entry-thumb, body.td-animation-stack-type0 .post
img{opacity:100}</style> <script type='text/javascript'>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};</script><link
rel='stylesheet' id='hugeit_custom_style-css'  href='http://www.thecordovatimes.com?hugeit_custom_css=1&#038;ver=4.7.5' type='text/css' media='all' /> <script type='text/javascript'>var wpcf7={"apiSettings":{"root":"http:\/\/www.thecordovatimes.com\/wp-json\/"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript' src='http://www.thecordovatimes.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script> <script type='text/javascript' src='http://www.thecordovatimes.com/wp-content/themes/Newspaper/js/tagdiv_theme.js'></script> <script type='text/javascript' src='http://www.thecordovatimes.com/wp-includes/js/comment-reply.min.js'></script> <script type='text/javascript' src='http://www.thecordovatimes.com/wp-includes/js/wp-embed.min.js'></script> <script type="text/css" id="tmpl-tribe_customizer_css">.tribe-events-list.tribe-events-loop.tribe-event-featured,.tribe-events-list#tribe-events-day.tribe-events-loop.tribe-event-featured,.type-tribe_events.tribe-events-photo-event.tribe-event-featured.tribe-events-photo-event-wrap,.type-tribe_events.tribe-events-photo-event.tribe-event-featured.tribe-events-photo-event-wrap:hover{background-color:#157f9d;}#tribe-events-content table.tribe-events-calendar.type-tribe_events.tribe-event-featured{background-color:#157f9d;}.tribe-events-list-widget.tribe-event-featured,.tribe-events-venue-widget.tribe-event-featured,.tribe-mini-calendar-list-wrapper.tribe-event-featured,.tribe-events-adv-list-widget.tribe-event-featured.tribe-mini-calendar-event{background-color:#157f9d;}.tribe-grid-body.tribe-event-featured.tribe-events-week-hourly-single{background-color:rgba(21,127,157,.7);border-color:#157f9d;}.tribe-grid-body.tribe-event-featured.tribe-events-week-hourly-single:hover{background-color:#157f9d;}</script><style type="text/css" id="tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover{background-color:#157f9d}#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured{background-color:#157f9d}.tribe-events-list-widget .tribe-event-featured,
.tribe-events-venue-widget .tribe-event-featured,
.tribe-mini-calendar-list-wrapper .tribe-event-featured,
.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event{background-color:#157f9d}.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single{background-color:rgba(21,127,157, .7 );border-color:#157f9d}.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover{background-color:#157f9d}</style> <script>jQuery().ready(function(){tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Cordova, AK","api_location":"Cordova","api_language":"en","today_icon":"rain-n","today_icon_text":"light rain","today_temp":[8,46.4],"today_humidity":93,"today_wind_speed":[2.7,1.7],"today_min":[8,46.4],"today_max":[8,46.4],"today_clouds":90,"current_unit":1,"forecast":[{"timestamp":1495141200,"day_temp":[5,42],"day_name":"Thu","owm_day_index":1},{"timestamp":1495227600,"day_temp":[4,40],"day_name":"Fri","owm_day_index":2},{"timestamp":1495314000,"day_temp":[4,39],"day_name":"Sat","owm_day_index":3},{"timestamp":1495400400,"day_temp":[4,39],"day_name":"Sun","owm_day_index":4},{"timestamp":1495486800,"day_temp":[3,38],"day_name":"Mon","owm_day_index":5}],"api_key":"17aa0dd026f22e09f52ad000002991c6"});});(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='http://www.thecordovatimes.com/wp-content/themes/Newspaper/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='http://www.thecordovatimes.com/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}
var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}
var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script> </body></html>
<!--
*** This site runs WP Super Minify plugin v1.5.1 - http://wordpress.org/plugins/wp-super-minify ***
*** Total size saved: 15.29% | Size before compression: 84970 bytes | Size after compression: 71978 bytes. ***
-->